12 月 102014
 

code-signing-certificate-usage-01 code-signing-certificate-usage-02 code-signing-certificate-usage-03 code-signing-certificate-usage-04 code-signing-certificate-usage-05使用自动选取证书对文件自动签名

signtool sign /a /v Setup.exe

指定证书对文件进行签名

signtool sign /n "深圳市XY科技有限公司" /v Setup.exe

使用存储在密码保护PFX文件中的证书对文件进行签名

signtool sign /f Cert.pfx /p password Setup.exe

对已签名的文件进行加盖时间戳

signtool timestamp /t http://timestamp.verisign.com/scripts/timstamp.dll /v Setup.exe

对文件进行一次性签名及加盖时间戳

signtool sign /a /t http://timestamp.verisign.com/scripts/timstamp.dll /v Setup.exe

验证签名及时间戳

signtool verify /pa /v Setup.exe

注:对文件进行签名和加盖时间戳时可以使用文件通配符批量处理

11 月 272014
 

[root@localhost bin]# cat /opt/openfire/logs/nohup.out
nohup: failed to run command `/opt/openfire/jre/bin/java’: No such file or directory
[root@localhost bin]#

[root@localhost bin]# vi /etc/sysconfig/openfire
# If you wish to override the auto-detected JAVA_HOME variable, uncomment
# and change the following line.
#JAVA_HOME=/usr/java/default
JAVA_HOME=/usr/lib/jvm/jre-1.7.0-openjdk.x86_64

[root@localhost bin]# /etc/init.d/openfire start
Starting openfire:
[root@localhost bin]# cat /opt/openfire/logs/nohup.out
Openfire 3.9.3 [2014-11-26 19:01:29]
管理平台开始监听 http://localhost.localdomain:9090
[root@localhost bin]#
[root@localhost bin]# netstat -lnt |grep 9090
tcp 0 0 :::9090 :::* LISTEN
[root@localhost bin]#

11 月 252014
 

相关引用:

http://www.ciscopress.com/articles/article.asp?p=1574301&seqNum=5

Configuring DHCP Server on a Router or Layer 3 Switch
Router(config)#ip dhcp pool internal

Creates a DHCP pool called internal.

Router(dhcp-config)#network 172.16.10.0 255.255.255.0

Defines the range of addresses to be leased.

Router(dhcp-config)#default-router 172.16.10.1

Defines the address of the default router for the client.

Router(dhcp-config)#dns-server 172.16.10.10

Defines the address of the Domain Name System (DNS) server for the client.

Router(dhcp-config)#netbios-name-server 172.16.10.10

Defines the address of the NetBIOS server for the client.

Router(dhcp-config)#domain-name fakedomainname.ca

Defines the domain name for the client.

Router(dhcp-config)#lease 14 12 23

Defines the lease time to be 14 days, 12 hours, 23 minutes.

Router(dhcp-config)#lease infinite

Sets the lease time to infinity; the default time is 1 day.

Router(dhcp-config)#exit

Returns to global configuration mode.

Router(config)#ip dhcp excluded-address 172.16.10.1 172.16.10.9

Specifies the range of addresses not to be leased out to clients.

Router(config)#service dhcp

Enables the DHCP service and relay features on a Cisco IOS router.

Router(config)#no service dhcp

Turns off the DHCP service. DHCP service is enabled by default in Cisco IOS Software.

11 月 252014
 

相关引用:

http://www.ciscopress.com/articles/article.asp?p=1574301&seqNum=4

Cisco-Inter-VLAN-Communication-01ISP Router

Router>enable
Moves to privileged mode.

Router>#configure terminal
Moves to global configuration mode.

Router(config)#hostname ISP
Sets the host name.

ISP(config)#interface loopback 0
Moves to interface configuration mode.

ISP(config-if)#description simulated address representing remote website
Sets the locally significant interface description.

ISP(config-if)#ip address 198.133.219.1 255.255.255.0
Assigns IP address and netmask.

ISP(config-if)#interface serial 0/0/0
Moves to interface configuration mode.

ISP(config-if)#description WAN link to the Corporate Router
Sets the locally significant interface description.

ISP(config-if)#ip address 192.31.7.5 255.255.255.252
Assigns IP address and netmask.

ISP(config-if)#clock rate 56000
Assigns a clock rate to the interface—DCE cable is plugged in to this interface.

ISP(config-if)#no shutdown
Enables the interface.

ISP(config-if)#exit
Returns to global configuration mode.

ISP(config-if)#router eigrp 10
Creates Enhanced Interior Gateway Routing Protocol (EIGRP) routing process 10.

ISP(config-router)#network 198.133.219.0
Advertises directly connected networks (classful address only).

ISP(config-router)#network 192.31.7.0
Advertises directly connected networks (classful address only).

ISP(config-router)#no auto-summary
Disables auto summarization.

ISP(config-router)#exit
Returns to global configuration mode.

ISP(config)#exit
Returns to privileged mode.

ISP#copy running-config startup-config
Saves the configuration to NVRAM.
CORP Router

Router>enable
Moves to privileged mode.

Router>#configure terminal
Moves to global configuration mode.

Router(config)#hostname CORP
Sets the host name.

ISP(config)#interface serial 0/0/0
Moves to interface configuration mode.

CORP(config-if)#description link to ISP
Sets the locally significant interface description.

CORP(config-if)#ip address 192.31.7.6 255.255.255.252
Assigns IP address and netmask.

CORP(config-if)#no shutdown
Enables the interface.

CORP(config)#interface fastethernet 0/1
Moves to interface configuration mode.

CORP(config-if)#description link to 3560 Switch
Sets the locally significant interface description.

CORP(config-if)#ip address 172.31.1.5 255.255.255.252
Assigns the IP address and netmask.

CORP(config-if)#no shutdown
Enables the interface.

CORP(config-if)#exit
Returns to global configuration mode.

CORP(config)#interface fastethernet 0/0
Enters interface configuration mode.

CORP(config-if)#duplex full
Enables full-duplex operation to ensure trunking will take effect between here and L2Switch2.

CORP(config-if)#no shutdown
Enables the interface.

CORP(config-if)#interface fastethernet 0/0.1
Creates a virtual subinterface and moves to subinterface configuration mode.

CORP(config-subif)#description Management VLAN 1 – Native VLAN
Sets the locally significant interface description.

CORP(config-subif)#encapsulation dot1q 1 native
Assigns VLAN 1 to this subinterface. VLAN 1 is the native VLAN. This subinterface uses the 802.1Q trunking protocol.

CORP(config-subif)#ip address 192.168.1.1 255.255.255.0
Assigns the IP address and netmask.

CORP(config-subif)#interface fastethernet 0/0.10
Creates a virtual subinterface and moves to subinterface configuration mode.

CORP(config-subif)#description Sales VLAN 10
Sets the locally significant interface description.

CORP(config-subif)#encapsulation dot1q 10
Assigns VLAN 10 to this subinterface. This subinterface uses the 802.1Q trunking protocol.

CORP(config-subif)#ip address 192.168.10.1 255.255.255.0
Assigns the IP address and netmask.

CORP(config-subif)#interface fastethernet 0/0.20
Creates a virtual subinterface and moves to subinterface configuration mode.

CORP(config-subif)#description Engineering VLAN 20
Sets the locally significant interface description.

CORP(config-subif)#encapsulation dot1q 20
Assigns VLAN 20 to this subinterface. This subinterface uses the 802.1Q trunking protocol.

CORP(config-subif)#ip address 192.168.20.1 255.255.255.0
Assigns the IP address and netmask.

CORP(config-subif)#interface fastethernet 0/0.30
Creates a virtual subinterface and moves to subinterface configuration mode.

CORP(config-subif)#description Marketing VLAN 30
Sets the locally significant interface description.

CORP(config-subif)#encapsulation dot1q 30
Assigns VLAN 30 to this subinterface. This subinterface uses the 802.1Q trunking protocol.

CORP(config-subif)#ip add 192.168.30.1 255.255.255.0
Assigns the IP address and netmask.

CORP(config-subif)#exit
Returns to interface configuration mode.

CORP(config-if)#exit
Returns to global configuration mode.

CORP(config)#router eigrp 10
Creates EIGRP routing process 10 and moves to router configuration mode.

CORP(config-router)#network 192.168.1.0
Advertises the 192.168.1.0 network.

CORP(config-router)#network 192.168.10.0
Advertises the 192.168.10.0 network.

CORP(config-router)#network 192.168.20.0
Advertises the 192.168.20.0 network.

CORP(config-router)#network 192.168.30.0
Advertises the 192.168.30.0 network.

CORP(config-router)#network 172.31.0.0
Advertises the 172.31.0.0 network.

CORP(config-router)#network 192.31.7.0
Advertises the 192.31.7.0 network.

CORP(config-router)#no auto-summary
Turns off automatic summarization at classful boundary.

CORP(config-router)#exit
Returns to global configuration mode.

CORP(config)#exit
Returns to privileged mode.

CORP#copy running-config startup-config
Saves the configuration in NVRAM.
L2Switch2 (Catalyst 2960)

Switch>enable
Moves to privileged mode.

Switch#configure terminal
Moves to global configuration mode.

Switch(config)#hostname L2Switch2
Sets the host name.

L2Switch2(config)#vlan 10
Creates VLAN 10 and enters VLAN-configuration mode.

L2Switch2(config-vlan)#name Sales
Assigns a name to the VLAN.

L2Switch2(config-vlan)#exit
Returns to global configuration mode.

L2Switch2(config)#vlan 20
Creates VLAN 20 and enters VLAN-configuration mode.

L2Switch2(config-vlan)#name Engineering
Assigns a name to the VLAN.

L2Switch2(config-vlan)#vlan 30
Creates VLAN 30 and enters VLAN-configuration mode. Note that you do not have to exit back to global configuration mode to execute this command.

L2Switch2(config-vlan)#name Marketing
Assigns a name to the VLAN.

L2Switch2(config-vlan)#exit
Returns to global configuration mode.

L2Switch2(config)#interface range fastethernet 0/2 – 4
Enables you to set the same configuration parameters on multiple ports at the same time.

L2Switch2(config-if-range)#switchport mode access
Sets ports 2–4 as access ports.

L2Switch2(config-if-range)#switchport access vlan 10
Assigns ports 2–4 to VLAN 10.

L2Switch2(config-if-range)#interface range fastethernet 0/5 – 8
Enables you to set the same configuration parameters on multiple ports at the same time.

L2Switch2(config-if-range)#switchport mode access
Sets ports 5–8 as access ports.

L2Switch2(config-if-range)#switchport access vlan 20
Assigns ports 5–8 to VLAN 20.

L2Switch2(config-if-range)#interface range fastethernet 0/9 – 12
Enables you to set the same configuration parameters on multiple ports at the same time.

L2Switch2(config-if-range)#switchport mode access
Sets ports 9–12 as access ports.

L2Switch2(config-if-range)#switchport access vlan 30
Assigns ports 9–12 to VLAN 30.

L2Switch2(config-if-range)#exit
Returns to global configuration mode.

L2Switch2(config)#interface fastethernet 0/1
Moves to interface configuration mode.

L2Switch2(config)#description Trunk Link to CORP Router
Sets locally significant interface description.

L2Switch2(config-if)#switchport mode trunk
Puts the interface into trunking mode and negotiates to convert the link into a trunk link.

L2Switch2(config-if)#exit
Returns to global configuration mode.

L2Switch2(config)#interface vlan 1
Creates virtual interface for VLAN 1 and enters interface configuration mode.

L2Switch2(config-if)#ip address 192.168.1.2 255.255.255.0
Assigns the IP address and netmask.

L2Switch2(config-if)#no shutdown
Enables the interface.

L2Switch2(config-if)#exit
Returns to global configuration mode.

L2Switch2(config)#ip default-gateway 192.168.1.1
Assigns the default gateway address.

L2Switch2(config)#exit
Returns to privileged mode.

L2Switch2#copy running-config startup-config
Saves the configuration in NVRAM.
L3Switch1 (Catalyst 3560)

Switch>enable
Moves to privileged mode.

Switch#configure terminal
Moves to global configuration mode.

Switch(config)#hostname L3Switch1
Sets the host name.

L3Switch1(config)#vtp mode sever
Changes the switch to VTP server mode.

L3Switch1(config)#vtp domain testdomain
Configures the VTP domain name to testdomain.

L3Switch1(config)#vlan 10
Creates VLAN 10 and enters VLAN-configuration mode.

L3Switch1(config-vlan)#name Accounting
Assigns a name to the VLAN.

L3Switch1(config-vlan)#exit
Returns to global configuration mode.

L3Switch1(config)#vlan 20
Creates VLAN 20 and enters VLAN-configuration mode.

L3Switch1(config-vlan)#name Marketing
Assigns a name to the VLAN.

L3Switch1(config-vlan)#exit
Returns to global configuration mode.

L3Switch1(config)#interface gigabitethernet 0/1
Moves to interface configuration mode.

L3Switch1(config-if)#switchport trunk encapsulation dot1q
Specifies 802.1Q encapsulation on the trunk link.

L3Switch1(config-if)#switchport mode trunk
Puts the interface into trunking mode and negotiates to convert the link into a trunk link.

L3Switch1(config-if)#exit
Returns to global configuration mode.

L3Switch1(config)#ip routing
Enables IP routing on this device.

L3Switch1(config)#interface vlan 1
Creates a virtual interface for VLAN 1 and enters interface configuration mode.

L3Switch1(config-if)#ip address 172.16.1.1 255.255.255.0
Assigns the IP address and netmask.

L3Switch1(config-if)#no shutdown
Enables the interface.

L3Switch1(config-if)#interface vlan 10
Creates a virtual interface for VLAN 10 and enters interface configuration mode.

L3Switch1(config-if)#ip address 172.16.10.1 255.255.255.0
Assigns the IP address and mask.

L3Switch1(config-if)#no shutdown
Enables the interface.

L3Switch1(config-if)#interface vlan 20
Creates a virtual interface for VLAN 20 and enters interface configuration mode.

L3Switch1(config-if)#ip address 172.16.20.1 255.255.255.0
Assigns the IP address and mask.

L3Switch1(config-if)#no shutdown
Enables the interface.

L3Switch1(config-if)#exit
Returns to global configuration mode.

L3Switch1(config)#interface fastethernet 0/24
Enters interface configuration mode.

L3Switch1(config-if)#no switchport
Creates a Layer 3 port on the switch.

L3Switch1(config-if)#ip address 172.31.1.6 255.255.255.252
Assigns the IP address and netmask.

L3Switch1(config-if)#exit
Returns to global configuration mode.

L3Switch1(config)#router eigrp 10
Creates EIGRP routing process 10 and moves to router config mode.

L3Switch1(config-router)#network 172.16.0.0
Advertises the 172.16.0.0 classful network.

L3Switch1(config-router)#network 172.31.0.0
Advertises the 172.31.0.0 classful network.

L3Switch1(config-router)#no auto-summary
Turns off automatic summarization at classful boundary.

L3Switch1(config-router)#exit
Applies changes and returns to global configuration mode.

L3Switch1(config)#exit
Returns to privileged mode.

L3Switch1#copy running-config startup-config
Saves configuration in NVRAM.
L2Switch1 (Catalyst 2960)

Switch>enable
Moves to privileged mode.

Switch#configure terminal
Moves to global configuration mode.

Switch(config)#hostname L2Switch1
Sets the host name.

L2Switch1(config)#vtp domain testdomain
Configures the VTP domain name to testdomain.

L2Switch1(config)#vtp mode client
Changes the switch to VTP client mode.

L2Switch1(config)#interface range fastethernet 0/1 – 4
Enables you to set the same configuration parameters on multiple ports at the same time.

L2Switch1(config-if-range)#switchport mode access
Sets ports 1–4 as access ports.

L2Switch1(config-if-range)#switchport access vlan 10
Assigns ports 1–4 to VLAN 10.

L2Switch1(config-if-range)#interface range fastethernet 0/5 – 8
Enables you to set the same configuration parameters on multiple ports at the same time.

L2Switch1(config-if-range)#switchport mode access
Sets ports 5–8 as access ports.

L2Switch1(config-if-range)#switchport access vlan 20
Assigns ports 5–8 to VLAN 20.

L2Switch1(config-if-range)#exit
Returns to global configuration mode.

L2Switch1(config)#interface gigabitethernet 0/1
Moves to interface configuration mode.

L2Switch1(config-if)#switchport mode trunk
Puts the interface into trunking mode and negotiates to convert the link into a trunk link.

L2Switch1(config-if)#exit
Returns to global configuration mode.

L2Switch1(config)#interface vlan 1
Creates a virtual interface for VLAN 1 and enters interface configuration mode.

L2Switch1(config-if)#ip address 172.16.1.2 255.255.255.0
Assigns the IP address and netmask.

L2Switch1(config-if)#no shutdown
Enables the interface.

L2Switch1(config-if)#exit
Returns to global configuration mode.

L2Switch1(config)#ip default-gateway 172.16.1.1
Assigns the default gateway address.

L2Switch1(config)#exit
Returns to privileged mode.

L2Switch1#copy running-config startup-config

11 月 242014
 

代码签名证书 (Code signing certificate) 是数字证书,有助于防止用户下载受感染的文件或应用程序。 如果由开发商签名的文件或应用程序在发布后被修改或受感染,系统会弹出浏览器警告,告知用户该文件或应用程序的来源无法验证。

Code Signing Certificates for Microsoft Authenticode
对 32 位 或 64 位用户模式(.exe、.cab、.dll、.ocx、.msi、.xpi 和 .xap 文件)和内核模式软件进行数字签名。

采用代码签名证书的好处:

1,依靠受信任的证书颁发机构 (CA) 减少安全警告
2,保护您的代码完整性和您的信誉
3,避免国内流氓安全软件企业对软件的误杀误报
工作原理:

开发商使用代码签名证书中的唯一私钥向代码或内容中添加数字签名。
用户下载或遇到已签名代码时,用户的系统软件或应用程序会使用公钥解密该签名。
系统查找含有它所信任或识别的 ID 的“根”证书,以验证该签名。
然后,将对该应用程序进行签名时所用的哈希值与下载的应用程序的哈希值进行比较。
如果系统信任该根证书且哈希值匹配,则继续下载或执行。
如果系统不信任该根证书或哈希值不匹配,那么系统会显示警告并中断下载过程,或下载过程失败。

^

code-signing-certificate-01 code-signing-certificate-02 code-signing-certificate-03 code-signing-certificate-04 code-signing-certificate-05 code-signing-certificate-06 code-signing-certificate-07code-signing-certificate-08 code-signing-certificate-09 code-signing-certificate-10 code-signing-certificate-11 code-signing-certificate-12

11 月 182014
 
默认为1修改为8
    nbproc      8

[root@localhost ~]# service haproxy restart
Stopping haproxy:                                          [  OK  ]
Starting haproxy: [WARNING] 317/114841 (1478) : Proxy 'status': in multi-process mode, stats will be limited to 

process assigned to the current request.
[WARNING] 317/114841 (1478) : stats socket will not work as expected in multi-process mode (nbproc > 1), you 

should force process binding globally using 'stats bind-process' or per socket using the 'process' attribute.
                                                           [  OK  ]
[root@localhost ~]# 


[root@localhost ~]# service haproxy restart
Stopping haproxy:                                          [  OK  ]
Starting haproxy:                                          [  OK  ]
[root@localhost ~]#



修改

全局配置
global
    log         127.0.0.1 local2

    chroot      /var/lib/haproxy
    pidfile     /var/run/haproxy.pid
    nbproc      8
    maxconn     4000
    user        haproxy
    group       haproxy
    daemon
    stats bind-process 1
    # turn on stats unix socket
    stats socket /var/lib/haproxy/stats


listen status
    bind-process 1
    bind *:8080
    stats enable
    stats hide-version
    stats uri /admin?stats
    stats auth admin:123456
    stats realm (Haproxy\ statistic)
    stats refresh 2s

等效
listen status 0.0.0.0:8080
    bind-process 1
    stats enable
    stats hide-version
    stats uri /admin?stats
    stats auth admin:123456
    stats realm (Haproxy\ statistic)
    stats refresh 2s